Classification and Error Analysis Procedures

Copy files from the class web page display the image.

1. Copy the following files from the class web page:
   - ginna_2000 7-band.hdr  Header for the ginna image
   - ginna 8-class-train.roi 8-class training set for the image
   - ginna 8-class-test.roi 8-class test data set for the image
   - Ginna Power Plant.kmz  Google Earth *.kmz file locating the power plant on Lake Ontario.

2. Load the ginna_7-band image into ENVI and display using bands 43, 25, and 15 for the Red, Green and Blue bands, respectively.  This will produce the CIR image that appears in Figure 1. (The easy way to do this is to right click on the image name in the Available Bands List and select "Load CIR to <new>").  Enlarge the image window to display the full scene.

Perform a Supervised Classification

1. Select Training Set Using Regions of Interest (ROI)
   a. Load the ginna 8-class-train.roi training set into ROI tool and display the training ROIs in the image. In the image menu, select Tools > Region of Interest > ROI Tool
   b. In the ROI tool menu select File > Restore ROIs, then select ginna 8-class-train.roi
      There will be eight classes listed in the ROI tool menu with matching colored polygons marking the areas for each of the ROIs in the image:
      - trn_bare-soil (sienna)  - trn_grs-field (green)
      - trn_forest (green3)  - trn_orchard (maroon)
      - trn_asphalt (yellow)  - trn_dark roof (orange1)
      - trn_water (blue)  - trn_paved (purple)
   c. Housekeeping:
      - Select the "off" radio button. This will turn off the ROI drawing tool so that you can move the zoom window in the image.
      - Select the Region #1 ROI at the top of the ROI Tool window by clicking on the leftmost box. The entire line should be highlighted and an asterisk should appear in the left box. Select Delete ROI.
   d. Examine the selected areas to understand the character of the areas selected.
      - You may hide individual ROIs by selecting a specific ROI name and selecting Hide ROIs. Redisplay the ROI by selecting Show ROIs and selecting the deleted ROI name.
      - Note that the training polygons
         - Avoid edges (mixed pixels)
         - Intentionally span the range of color/brightness for the selected class, e.g. wet & dry soil, glint & non-glint water, bright & dark asphalt

Figure 1: CIR display of ginna image.
Display a 2-D scatterplot and import ROIs

a. Display a 2-D scatterplot using bands 25 and 33.
   b. Select File > Import ROIs. The Import ROIs to Scatter Plot dialog appears.
   c. Select Select all Items and click OK. Points in the scatterplot whose 2-band gray values match those of pixels in the training areas appear as colored points in the scatterplot and in the image. This is essentially a 2-band classification. If there is conflict between classes (i.e., grass/orchard, asphalt/dark roof), the last class defined in the ROI list will be shown as the dominant class. (To see the coverage of an individual class, load classes into the scatterplot one at a time.)
   d. Hide the training areas to better view the scatterplot classification. In the ROI window select Select All and Hide ROIs. They will remove the ROI mask showing the location of the training data and leave marked only those pixels that match the 2-band combination in the scatterplot.
   e. Note that there areas in the image that are not captured by the scatterplot classification. Are there any areas that are obviously misclassified?
   f. Close the scatterplot.

2. (Optional) Display the ROIs in the n-dimensional visualizer.

a. In the ROI Tool Window, Select File > Export ROIs to n-D visualizer.
   b. In the Select Input File Window, Select the ginna_200 7-band image and click OK.
   c. In the n-D Visualizer Input ROIs window, click on Select All Items and click OK. The n-D visualizer and window n-D controls window.
   d. In the n-D Controls window, click on 3 or more bands to activate the n-D Visualizer display.
   e. Select Options > Show Axes. This will make the axes visible in the n-D visualizer window. Only the first 2 bands are apparent at first.
   f. Change the speed to 20, and click on Start.
   g. If you select only 3 bands (I suggest bands 3, 5, and 6) you can manually operate the axes rotation by selecting: Options > 3-D Drive Axes.
   h. Challenge: can you find an orientation in which the dark roof (orange) and asphalt (yellow) classes are distinct?

3. Perform a maximum-likelihood (ML) classification using the ginna 6-class-train.roi

a. In the ENVI Classic toolbar, select Classification > Supervised > Maximum Likelihood
   b. Select the ginna_200 7-band image. Select OK.
   c. In the Maximum Likelihood Parameters window:
      i. Click on Select All Items in Select Classes area.
      ii. Set the Probability Threshold to "Single-value" and set the Probability Threshold to 0.99. This will apply the same threshold to every class, and will result in classification of most pixels. The range of acceptable values is between 0.0 and 1.0. ENVI Classic will not classify pixels with a probability lower than this value. The utility is difficult to use effectively.
      iii. Set the Data Scale Factor to 255. The scale factor is a division factor used to convert integer scaled reflectance or radiance data into floating-point values. For reflectance data scaled into the range of zero to 10,000, set the scale factor to 10,000. For uncalibrated integer data, set the scale factor to the maximum value the instrument can measure \(2^n - 1\), where \(n\) is the bit depth of the instrument. For 8-bit instruments (such as MISI) the scale factor is 255, for 10-bit instruments (such as NOAA 12 AVHRR) the scale factor is 1023, for 11-bit instruments (such as IKONOS) the scale factor 2047.
      iv. Name the image: ginna_ML_8-class.img
v. Select "No" for the Output Rule Images.
vi. Select OK

4. **Display the classified image and visually evaluate the results.**
   a. Note that the colors match the colors chosen for the training data.
   b. In the Max Like image window, select Tools > 2-D Scatterplot, and select bands 25 and 33 from the Ginna image. This will allow you to use image dance to explore the classifications in the scatterplot by dragging the cursor in the Max Like image window.
   c. Note the near perfect classification of bare soil.
   d. Examine the unclassified areas using image dance.

5. **Improve the Classification**
   a. One obvious problem is the misclassification of water along the shoreline as asphalt. Although the training set for water spanned the bright and dark areas on the water, it did not capture the brightest water pixels near the shore. One can improve the classification by including samples of these pixels in the water training set.
   i. Go to the ROI Tool Window. If it is no longer open, open it (step 1a).
   ii. If the ROIs are not displayed, select *Show ROI*, the *Select All Items*, and *GO*.
   iii. Select the *Zoom* radio button at the top of the ROI Tool.
   iv. In the Ginna image window, move the zoom box to the shoreline area on the left
   v. Select *trn_water* (Blue) class. You will be adding to this training data.
   vi. In the zoom box, draw a polygon in the water along the shore on left side of the image where the water has been misclassified as asphalt. Be careful to avoid including the borderline trees (and their shadows) and the exposed soil along the edge of the water.
   b. Another problem is the misclassification of the power plant where buildings are either unclassified or misclassified as pavement. In that same area, grass lawns are classified as asphalt or orchard. In order to eliminate these problems, we would need a 9th class for bright-roofed buildings and a 10th class to capture the lawns. Select two sets of samples, one for training, and one for testing the classifier of each of the two categories.
   i. Define training data for the bright-roofed buildings:
      – Go to the ROI Tool Window and select New Region. A new color will be assigned automatically. You may change the color by right-clicking on the color and selecting a new color. Hit RETURN before moving on, or the color selection will not be saved.
      – Name the region train: *trn_light-roof*.
      – Select light-toned roof areas from the power plant buildings.
      – Select another light-toned roof area and label it *tst_light-roof*.
      – Repeat the above procedure for a grass lawn area within the plant compound. Label the areas *trn_grs-lawn* and *tst_grs-lawn*.
   ii. Rerun the maximum likelihood classifier using the new 10-class set of ROIs (Steps 4a-c).
      – Select only the 10 training classes.
      – Set the probability threshold to "Single Value" and set the Probability Threshold to 0.99.
      – Set the Data Scale Factor to 255.
      – Name the new image "ginna_ML_10-class.img"
      – Select "Yes" for the Output Rule Images with the name " ginna_ML_10-class_rule.img"
      – Select OK.
iii. Visually examine the new classification.
   – Has your new training set recaptured all of the water pixels?
   – Have all the unclassified pixels been classified?
   – Are the roofs now distinguishable from the pavement?
   – What has happened with the near-perfect bare-soil classification?
   – Are there any other obvious changes, problems or improvements?

Create a confusion (contingency) Matrix

ENVI’s confusion matrix function allows comparison of two classified images (the classification and the “truth” image), or a classified image and ROIs representing ground truth observations. We will examine the latter case.

Using Ground Truth Regions of Interest

1. Delete the training ROIs from the ROI tool window. In the ROI tool window, highlight all of the ROIs beginning with "trn_" by clicking in the left column while holding down the CTRL button, then select Delete ROI. (This is not absolutely necessary, but will avoid unnecessary confusion.)

2. Load the test ROIs (ginna 8-class-test.roi) into the ROI tool window. You should now have 10 ROIs in the window with names beginning with "test", the 2 that you created plus the 8 you just loaded. Delete any extraneous ROIs to minimize confusion.


4. In the Classification Input File Window select the classified image ginna_ML_10-class.img. Select OK. The Match Classes Parameters window appears.

5. Match each of the test ROIs with the corresponding training training ROI and select Add Combination as shown at right. Continue until only the unclassified category remains in the Classification image list.

6. Select OK. The Confusion Matrix Parameters window appears. Select all outputs: Confusion Matrix in pixels and percent as well as the Accuracy Assessment Report.

7. Select OK. The Class Confusion Matrix window appears.

The report shows the overall accuracy, kappa coefficient, confusion matrix, errors of commission (percentage of extra pixels in class), errors of omission (percentage of pixels left out of class), producer accuracy, and user accuracy for each class.

Prod. Acc.: probability that a pixel known to be in class is assigned to class X.
User Acc.: probability that a pixel assigned to class X actually belongs to class X.
Confusion matrix: output shows these accuracy assessments for each class.
8. Evaluate the Confusion Matrix
   – How "good" is the classification according to the confusion matrix?
   – Consider the User's and Producer's Accuracies. Is one significantly better than the other?
   – Are there any obvious problems with the classification based on the confusion matrix?
   – Compare the classified image to the original image:
     – How would you rate the classification based on a visual evaluation of the classification image?
       ▪ How does your visual evaluation compare to the numerical evaluation?
       ▪ Does the confusion matrix capture the uncertainties in the classification?
       ▪ For instance consider the water class. Is the classification really 100% accurate?
       ▪ Are there water pixels that are not classified as water?
       ▪ Are there pixels classified as water that should not have been?
       ▪ Are there pixels that should have remained unclassified: e.g, cars in the parking lot, buildings, ..

Use the Rule Images to adjust the classification.

6. View the Rule images
   The rule images are gray-value images showing the discriminant function value for each pixel. The brightness of a pixel represents the probability that the pixel belongs to a particular class. There is one rule image for each class identified by an ROI. Regardless of the original classification results, one may redo the classification by adjusting the thresholds used for each rule image.

   a. Select
      Classification > Post Classification > Rule Classifier

   b. Select the rule images. If you did not name the rule images during classification, this will be the 500x800x10 image set.

   Note: the colors assigned to the rule images are ENVI's default color pallet, not the colors used to define the training or test ROIs. You can reset the colors to match those in the ROIs by selecting Options > Edit Class colors/names. This window allows you to reset each class color individually.

   c. Enter a 0.00 in the Set All Thresholds box and select Set All Thresholds. This sets the value for the discriminant function.

   d. Select Quick Apply to display the resulting classified image. Since a limit has been placed on the discriminant functions, there are pixels which do not meet the classification criterion for any of the classes. These appear black in the classified image.
e. *For a given class, display the* histogram to get an idea of the overall distribution for the specific discriminant function. Note: the range of the distribution function is very large and most of what is of interest is in the higher values. Positive numbers represent a high probability of correct classification. As the values decrease and become negative, the probability of correct classification decreases. Consider the distribution function for bare soil which ranges from -2200 to 16.7 (see figure below). In order to view the upper range of the scale, adjust the scale by selecting *Edit > Plot Parameters* and changing the lower limit of the x-axis. In the example, a value of -400 makes the important details of the distribution visible.

![Histograms and Plot Parameters](image)

f. Adjust the values of the thresholds for the classes as a group or individually. Use *Quick Apply* to see the effect of your choice on the classification.

- **Water**
  i. Adjust the rule image to capture as much of the water as possible. Can that be done without misclassifying land features as water?
  ii. Locate the locus of water on the 2-D histogram. Can you define a locus that works better than can be done with the rule image?

- **Asphalt**
  i. Adjust the rule image to capture as much of the roads and parking lots without including the water at the shoreline. Other than the shoreline water, are there other classes for which there is misclassification?
  ii. Display the 2-D histogram using bands 25 and 33 of the misi_2000 image. Based on the unclassified and misclassified asphalt pixels in the rule image, how would you modify the training data to better characterize the class. You could:
    - eliminate all or a part of a training area that is causing confusion,
    - add new areas to the training data.
    - Define another training set (asphalt2) to be classified separately in order to capture a region that cannot be included with the original training data without causing confusion with another class.
  iii. Look for clusters (classes) adjoining the asphalt areas in the 2-D histogram. These are classes that will be most likely to be misclassified as asphalt.
The tasks that follow are entirely optional. They are useful for producing usable maps from classified images, but are not critical for this class.

Displaying ROC curves

Receiver Operating Characteristic (ROC) Curves visualize a classifier's performance in order to select the proper decision threshold. The ROC Curves compare a series of rule image classification results for different threshold values with ground truth information. ENVI can calculate a ROC curve using either a ground truth image or using ground truth regions of interest (ROIs). A probability of detection (P_d) versus probability of false alarm (P_fa) curve and a P_d versus threshold curve are reported for each selected class (rule band).

For more information, see the following reference:

A. P. Bradley, 1997, The use of the area under the ROC Curve in the evaluation of machine learning algorithms, Pattern Recognition, V. 30, No.7, pp 1145-1159.

ROC curves may be created using either a reference image or ROIs. We only consider the procedure with ground truth images here.

Using Ground Truth Image

1. Create a Ground Truth Image.
   – Activate the ROI Tool window
   – Select Options > Create Class Image from ROIs
   – Select All Items
   – Select OK
   – Name the image "Ground Truth Image" and select OK


3. From this dialog, choose the classification rule image. (If you did not name this image it will appear as one of the memory images with 6 bands.) Each band selected in the rule image is used to generate a ROC curve. Each rule band is mapped to a ground truth class.

4. From the Ground Truth Input File dialog, select the ground truth image.

5. When the Match Classes Parameters dialog appears, match the ground truth classes with the rule image classes by clicking on the matching names in the two lists and clicking Add Combination. The class combinations are displayed in a list at the bottom of the dialog. If the ground truth and classification classes have the same names, they are matched automatically.

6. After all the combinations are made, click OK. The ROC Curve Parameters dialog appears.

7. Click the Classify by toggle button and select “Maximum Value”.
   (If your rule images are from the Minimum distance or SAM classifier, classify by minimum value. If your rule images are from the Maximum Likelihood classifier, classify by maximum value.)

8. In the Min and Max parameters text boxes, type 0 for the minimum and 100 for the maximum.
(Rule images are classified at N (specified by Points per ROC curve) evenly spaced thresholds between (and including) the Min and Max values. Each of these classifications is compared to the ground truth and becomes a single point on a ROC curve. For example, if your rule images are from the maximum likelihood classifier, the manual recommends a min value of 0 and max value of 1. (This, however, did not work for me.)

9. In the Points per ROC Curve text box, enter the number of points used to create each ROC curves. The more points you use, the smoother the curves will be. Since it's a relatively small data set I used 50 to create the curves pictured below.

10. In the ROC curve plots per window text box, enter the number of plots per window. Since there are only six classes, enter 6. When there are many more classes, it is useful to split up the display to avoid overlap and confusion.

11. Select whether to output probability of detection versus threshold plot by selecting the Yes or No check box.

12. Click OK. The ROC curves and probability of detection curves appear in plot windows. (Note: the colors do not match the colors assigned to the ROI classes.)

(a) Probability of False Alarm vs. Probability of Detection

As the false alarm rate increases the probability of detection increases. In other words, as the number of pixels in the test data set that are correctly classified increases, the number of pixels that are misclassified also increases. The idea is to select a threshold that provides the best classification with the minimum error rate. The red and yellow classes maintain a very high Probability of Detection for False Alarm Rates as low as about 8%. For lower False Alarm Rates the Probability of Detection decreases rapidly as well. For the cyan class, the tradeoff is more troublesome. There is already a 10% false alarm rate when the probability of detection is only about 85%.

(b) Threshold Value vs. Probability of Detection

For the red and yellow classes, a threshold of 5 would probably be appropriate. For the cyan class, a threshold of about 6 would correspond to a probability of detection of ≈85% with a 9% false alarm rate.

(a) Probability of False Alarm vs. Probability of Detection  
(b) Threshold Value vs. Probability of Detection
Post Processing Data Manipulation

Majority/Minority Analysis

Use Majority/Minority Analysis to apply majority or minority analysis to a classification image. Use majority analysis to change spurious pixels within a large single class to that class. You enter a kernel size and the center pixel in the kernel will be replaced with the class value that the majority of the pixels in the kernel has. If you select Minority analysis, then the center pixel in the kernel will be replaced with the class value that the minority of the pixels in the kernel has.

1. Select Classification > Post Classification > Majority/Minority Analysis.
2. When the file selection dialog appears, select the classification input file.
3. In the list of classes, click on the classes that you want to apply the analysis to.
   Note: If the center pixel is from a class that was not selected in the "Select Classes" list, that pixel will not be changed. However, center pixels of selected classes can be changed into a class that is not selected if the unselected class is the majority class in the kernel.
4. Select the analysis method, by clicking the corresponding toggle button.
5. Enter or select a kernel size.
   · Kernel sizes are odd and the kernels do not have to be square. Larger kernel sizes produce more smoothing of the classification image.
   · If you select "Majority" analysis, enter the "Center Pixel Weight."
   · The center pixel weight is the weight used to determine how many times the class of the center pixel is counted when determining which class is in the majority. For example, if you enter a weight of "1," ENVI will count the center pixel class only one time; if you enter "5," ENVI will count the center pixel class five times.
6. Select output to "File" or "Memory."
7. Click "OK."
   The resulting file is listed in the Available Bands List.

Clump and Sieve

Clump and Sieve provide means for generalizing classification images. Sieve is usually run first to remove the isolated pixels based on a size (number of pixels) threshold, and then clump is run to add spatial coherency to existing classes by combining adjacent similar classified areas. Compare the pre-calculated results in the files CAN_SV.IMG (sieve) and CAN_CLMP.IMG (clump of the sieve result) to the classified image CAN_PCLS.IMG (parallelepiped classification) or calculate your own images and compare to one of the classifications.

Sieve

Use Sieve Classes to solve the problem of isolated pixels occurring in classification images. Sieving classes removes isolated classified pixels using blob grouping. Low pass or other types of filtering could be used to remove these areas, but the class information would be contaminated by adjacent class codes. The sieve classes method looks at the neighboring 4 or 8 pixels to determine if a pixel is grouped with pixels of the same class. If the number of pixels in a class that are grouped is less than the value that you enter, those pixels will be removed from the class. When pixels are removed from a class using sieving, black pixels (unclassified) will be left.
1. Select Classification > Post Classification > Sieve Classes. When the Classification Input File dialog appears, select a classified.
   Note: Only classified images can be selected (based upon the file type described in the image's header).
2. Click "OK." The Sieve Parameters dialog appears with all of the available classes in the image listed in the "Select Classes" list.
3. Select the classes on which to perform sieving by clicking on the class names in the list.
   Note: Any classes not selected for sieving will be passed to the output image unchanged.
4. Enter the minimum number of pixels contained in a class group in the "Group Min Threshold" text box. Any groups of pixels smaller than this value will be removed from the class.
5. Use the arrow toggle button to select the number of neighboring pixels (4 or 8) to look at when determining the number of pixels in a class group.
   The four-neighbor region around a pixel consists of the two adjacent horizontal and two adjacent vertical neighbors. The eight-neighbor region around a pixel consists of all the immediately adjacent pixels.
6. Select output to "File" or "Memory."
7. Click "OK" to start the processing.

**Clump**
Use Clump Classes to clump adjacent similar classified areas together using morphological operators. Classified images often suffer from a lack of spatial coherency (speckle or holes in classified areas). Again, low pass filtering could be used to smooth these images, but the class information would be contaminated by adjacent class codes. Clumping classes solves this problem. The selected classes are clumped together by first performing a dilate operation and then an erode operation on the classified image using a kernel of the size specified in the parameters dialog.

1. Select Classification > Post Classification > Clump Classes. When the Classification Input File dialog appears, select a classified image and perform any spatial subsetting.
   Note: Only classified images can be selected (based upon the file type described in the image's header).
2. Click "OK." The Clump Parameters dialog appears with all of the available classes in the image in the "Select Classes" list.
3. Select the classes on which to perform clumping by clicking on the class names in the list.
   Note: Any classes not selected for clumping will be passed to the output image unchanged.
4. Enter the desired morphological operator size in the "Rows" and "Cols" text boxes.
5. Select output to "File" or "Memory."
6. Click "OK" to start the processing.
Combine Classes

The Combine Classes function provides an alternative method for classification generalization. Similar classes can be combined to form one or more generalized classes. Combining classes or removing the "unclassified" class effectively deletes those individual classes. Examine the pre-computed image CAN_COMB.IMG or perform your own combinations as described below.

1. Select Classification > Post Classification > Combine Classes. When the Classification Combine Classes dialog appears, select a classified image and perform any spatial subsetting using standard ENVI procedures.

2. After the input classification data has been selected, click "OK." The Combine Classes Parameters dialog appears.

3. In the Combine Classes Parameters dialog, select a class for input by clicking on a name in the "Input Classes" list. The selected class name appears in the "Input Class" text box.

4. Select an output class by clicking on a class name in the "Output Classes" list. When both the input and output classes have been selected, click "Add Combination" to finalize the selection. The new, combined class to be created are shown in the "Combined Classes" list at the bottom of the dialog. For example, selecting region 1 as the input and region 3 as the output causes the string region 1 -> region 3 to appear in the "Combined Classes" list. To deselect combined classes, click on the name in the "Combined Classes" list.

5. Click "OK" to combine the contents of the input class into the output class. When the Combine Classes Output dialog appears, select output to "File" or "Memory."

A status window appears while the classes are processed. The new classified image name is added to the Available Bands List where it can be displayed using standard ENVI procedures.

Edit Class Colors

When a classification image is displayed, you can change the color associated with a specific class by editing the class colors.


2. Click on one of the class names in the Class Color Mapping dialog and change the color by dragging the appropriate color sliders or entering the desired data values. Changes are applied to the classified image immediately. To make the changes permanent, select File > Save Changes in the dialog.

Interactive Classification Overlays

In addition to the methods above for working with classified data, ENVI also provides an interactive classification overlay tool. This tool allows you to interactively toggle classes on and off as overlays on a displayed image, to edit classes, get class statistics, merge classes, and edit class colors.

1. Display band 4 of CAN_TMR.IMG as a grayscale image using the Available Bands List.

2. From the Main Image Window menu bar, select Overlay > Classification.

3. Choose one of the available classified images in the Interactive Class Tool Input File dialog and click OK. The Interactive Class Tool dialog will appear and each class will be listed with it’s corresponding colors.

4. Click in each “On” check box to toggle display of each class as an overlay on the grayscale image.

5. Try the various options for assessing the classification by clicking on Options > Function.

6. Choose Edit > Function to interactively change the contents of specific classes.

7. Select File > Save Image As > Device in the Image Window (where Device is either Postscript or Image) to burn in the classes and output to a new file.
8. Select File > Cancel to exit the interactive tool.

**Overlaying Classes on an Image**

Use Overlay Classes to produce an image map with a color composite or grayscale background image and the classes overlaid in color. It outputs a three-band RGB image that can be displayed using standard ENVI procedures.

You can also overlay classes using the Overlay menu in the Main Image window.

Note: Due to the nature of the classification overlay, the background image should be stretched and saved to byte output images prior to overlay.

1. Select Classification > Post Classification > Overlay Classes.
2. When the Classification Input File dialog appears, select the classification.
3. When the Input Overlay RGB Input Bands dialog appears, click sequentially on the red, green, and blue bands to be used for the background image.
   - If a grayscale background is desired, click on the same spectral band for the RGB inputs.
   - The input files must be byte images (i.e., files containing values between 0 and 255).
4. Click "OK" to continue. When the Class Overlay to RGB Parameters dialog appears, select the desired classes to overlay on the background image by clicking on the toggle button associated with the class name in the list.
5. Select output to "File" or "Memory."
6. Click "OK" to create the class overlay image.

Note: If your display is set to 8-bit color, the class overlay image may appear incorrect when displayed due to the color quantization. However, on output, it will be correct.

**Calculating Buffer Zone Images**

Use Buffer Zone Image to create a buffer zone image from a classified image. In the buffer zone image every pixel has a floating point or integer value that is defined as the distance from that pixel to the nearest pixel of the selected class or classes in units of pixels. You designate a maximum distance value and the result is that any pixels with a distance larger than that value will be set to the maximum distance value. An example of a buffer zone image is shown in the figure below.

1. Select Classification > Post Classification > Buffer Zone Image.
2. When the file selection dialog appears, select the input classification file and any spatial subsetting. The Buffer Zone Image Parameters dialog appears.
3. In the list of classes, click on the class names to select which class(es) to measure the distance to.
   Note: If more than one class is selected, the distance will be from the pixel to the nearest class.
4. Click the "Maximum Distance" arrow increment buttons to set the maximum distance to measure, or type the value (in pixels) into the corresponding text box. Any pixels with a distance larger than this value will be set to the maximum distance value.
5. From the Distance Kernel button menu, select "Floating Point" or "Integer" output.
6. Select output to "File" or "Memory."
7. Click "OK."
Classes to Vector Layers
Load the pre-calculated vector layers onto the grayscale reflectance image for comparison to raster classified images, or execute the function and convert one of the classification images to vector layers.

• To Load the pre-calculated vector layers produced from the clumped classification image above:
  1. Select Overlay > Vectors in the Main Image Display with the clumped image CAN_CLMP.IMG displayed.
  2. Choose File > Open Vector File > ENVI Vector File in the Display Vector Parameters dialog and choose the files CAN_V1.EVF AND CAN_V2.EVF. Click on Apply to load the vector layers onto the image display.
  3. The vectors derived from the classification polygons will outline the raster classified pixels.

• To complete your own Classification to Vector conversion:
  1. select Classification > Post Classification > Classification to Vector and choose a classified image or the generalized image CAN_CLMP.IMG as the Raster to Vector input image.
  2. When the Raster to Vector Input Band dialog appears, select the desired input classification file and perform any subsetting.
  3. When the Raster to Vector Parameters dialog appears, select the desired class names to convert to vector polygons by clicking on the class names.
  4. Use the arrow toggle button to select whether to output each selected class to a separate vector layer or to output all of the classes to a single layer.
     If you output all of the classes to a single layer, attributes that include the class number, polygon length, and area will be created for each polygon.
  5. Select output to "File" or "Memory."
  6. Click "OK" to make a polygon vector layer for each class selected.
     If you select to output each class to a separate layer, each selected class is saved to a separate vector file with an ",_1", "_2", etc. appended to the root name.

Classification Keys Using Annotation
A map key consists of colored squares and corresponding labels for each map item or class in a classification image. Map keys can be defined interactively and are automatically created as class keys for classification images. Vector keys are automatically created for vector layers in the appropriate colors with the layer names as labels. Vector keys show the vector symbol used for points, a line for polylines, and a square outline for polygons.

1. In the Annotation dialog, select Object > Map Key.
2. Click the left mouse button at the desired location to position the map key.
   • To delete the map key, press the middle mouse button.
3. Click "Edit Map Key Items" to define or change items in the map key.
4. When the Map Key Object Definition dialog appears, select from the list of Key items.
   • To add additional items to the list, click "Add Item."
   • To delete an item, highlight it in the list and click "Delete Item."
   • To change the name of the item, enter the new name in the "Object Name" text box.
   • To define the color of the box, select the desired color using the "Color" menu.
• To add additional colors, enter the DN values in the "R," "G," and "B," text boxes for red, green, and blue respectively.
   The newly defined color appears as black in the image but will be correct upon output.
• To change the fill type in the box, use the "Fill" menu.
• To control the fill type, use the "Orien" and "Spc" parameter boxes.
• For vector keys, an "Object Type" button menu is included and has polygon, polyline, and point selections.
• For a vector polygon item, use the "Fill" button menu and "Orien" and "Space" parameter boxes to select the polygon fill type.
• For a vector polyline item, use the "Line Style" button menu to select different line styles.
• For a vector point item, use the "Symbol" menu to select the symbol type to be shown in the key.

5. Follow these steps to change other parameters within the Annotation dialog.
   • To set a background color select the desired color from the "Back" pulldown menu in the Annotation dialog.
   • To change the text font for the key, the size, and the thickness of the letters, select from the options described in Working with Text Annotation.
   • To change class colors, see Mapping Class Colors for detailed instructions.

**Saving Map Key Annotation**

1. In the Map Key Object Definition dialog, click the "Save" button.
2. At the prompt, enter an output file name.

ENVI writes the key to a file. Map key files should be saved with the file extension .key for consistency, but may be saved using other extensions at your discretion.

**Restoring Saved Map Key Files**

1. In the Map Key Object Definition dialog, click the "Restore" button.
2. Select the desired input file.