Classification and Error Analysis Procedures

1. Copy the image, training ROI, and test ROI files from the class web page:
   OLI_Ithaca_11-Oct-2015_7bnd: image and header
   OLI_Ithaca_8class_train.roi; OLI_Ithaca_8class_test.roi
   Display the image (as in Figure 1), along with the Red/IR scatterplot.

2. Identify the classes.
   Given the land use classes in the Ithaca area, a reasonable, generally representative set of simple land cover classes would be:

<table>
<thead>
<tr>
<th>Category</th>
<th>Sub-category</th>
<th>Name-train</th>
<th>Name-test</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Water</td>
<td></td>
<td>trn_water</td>
<td>tst_water</td>
<td>Blue</td>
</tr>
<tr>
<td>Bare soil</td>
<td></td>
<td>trn_soil</td>
<td>tst_soil</td>
<td>Orange2</td>
</tr>
<tr>
<td>Vegetation</td>
<td>Crop-emergent</td>
<td>trn_veg-emrg</td>
<td>tst_veg-emrg</td>
<td>Sienna</td>
</tr>
<tr>
<td></td>
<td>Crop-medium growth</td>
<td>trn_veg-med</td>
<td>tst_veg-med</td>
<td>Green</td>
</tr>
<tr>
<td></td>
<td>Crop-full growth</td>
<td>trn_veg-full</td>
<td>tst_veg-full</td>
<td>Green3</td>
</tr>
<tr>
<td>Forest</td>
<td></td>
<td>trn_forest</td>
<td>tst_forest</td>
<td>Thistle</td>
</tr>
<tr>
<td>Manmade</td>
<td>Asphalt &amp; Concrete</td>
<td>trn_asph-conc</td>
<td>tst_asph-conc</td>
<td>Yellow</td>
</tr>
<tr>
<td>Low-density residential</td>
<td></td>
<td>trn_LDres</td>
<td>tst_LDres</td>
<td>Magenta</td>
</tr>
</tbody>
</table>

Figure 1. a) OLI image of Ithaca from 11 Oct 2015; b) Red/IR scatterplot of the OLI image.
It is often worthwhile to explore the data in the scatterplot space to get a sense of the distributions. An example of such an exploration is shown in Figure 2. Since the scatterplot shows only 2-bands at a time, the view is usually too limited to perform an effective classification; however, it can serve as a useful guide for identifying training data sets. I encourage you to repeat the selection illustrated below, and to examine any variations that catch your eye.

The yellow appears to correspond man-made materials, especially roads, roofs. The areas that are highlighted in the image are large enough to fill (pure pixels). That may be why the airport is not highlighted. Orange corresponds to bare soil areas. Sienna (Brown) is associated with areas with emergent vegetation, with a slightly lower red reflectance and a stronger IR reflectance. The dense vegetation – mostly crops – is captured by the dark green (Green3), while the medium vegetation cover is indicated by the light green (Green). The forested areas cover a large, amorphous region of the scatterplot (Thistle), and Blue highlights the locus of water.

The water class could be defined simply as a threshold of the IR band. The other classes all require a minimum of two bands. A transition region is labeled with Cyan. These are mostly mixed pixels that include some portion of water. The cyan color appears most obviously along the edges of the lake.

Figure 2. a) OLI image with scatterplot region overlay; b) Red/IR scatterplot of the OLI image showing ROI selection.
The usual procedure is to select the training data using regions of interest (ROIs) defined by selecting representative areas in the image. The selection is based on visual identification of areas, and is necessarily limited in scope. The goal is to pick representative areas with pixels that will categorize the full category. A gray-scale version of the Ithaca OLI image is shown in Figure 3a, and the distribution of those pixels in the 2-D scatterplot is shown in Figure 3b. In addition to the classes identified in the scatterplot, a selection has been made for a high-density residential area (Cayuga Heights – Magenta).

![Figure 3. Image-selected ROIs for 8-classes a) plotted on the image; b) plotted on the Red/IR scatterplot.](image)

Note that the training sets do not span the range of values for any class. Since the selection is based on visual interpretation, the identified pixels tend to cluster within the overall range, and in several cases, it appears that they have missed the bulk of the spectral area covered by the class. This is true for the water class, even though the training data include more than a third of the pixels in Cayuga Lake, including the highly sedimented pixels at the southern end of the lake! This suggest that it will be necessary to be very generous in specifying the cutoff values in most cases.

Also note that the high density residential area almost completely overlaps with the forest class. This is a case where there may be some hope of separating the two classes with the extra spectral bands.
3. **Perform a maximum-likelihood (ML) classification using the OLI_Ithaca_8class_train.roi**

   - **Import the training data**
     1. In the image window, select: Tools > Region of Interest > Restore Saved ROI file
     2. Select: OLI_Ithaca_8class_train.roi

   - **In the ENVI Classic toolbar, select Classification > Supervised > Maximum Likelihood**, and select the OLI_Ithaca_11-Oct-2015_7bnd.img. Select OK.

   - **In the Maximum Likelihood Parameters window:**
     1. Select All Items.
     2. Set the Probability Threshold to "Single-value", and set the Probability Threshold to 0.1. This will apply the same threshold to every class, and will result in classification of most pixels. The range of acceptable values is between 0.0 and 1.0. ENVI Classic will not classify pixels with a probability lower than this value. The utility is difficult to use effectively.
     3. Set the Data Scale Factor to 1.
        - The instructions for this parameter are that the scale factor is a division factor used to convert integer scaled reflectance or radiance data into floating-point values. For reflectance data scaled into the range of zero to 10,000, set the scale factor to 10,000. For uncalibrated integer data, set the scale factor to the maximum value the instrument can measure $2^n - 1$, where $n$ is the bit depth of the instrument. For 8-bit instruments (such as MISI) the scale factor is 255, for 10-bit instruments (such as NOAA 12 AVHRR) the scale factor is 1023, for 11-bit instruments (such as IKONOS) the scale factor 2047, for the OLI, a 12-bit instrument, the scale factor is 4095. In my experience, this not worth the effort.
     4. Name the image, e.g., OLI_Ithaca_ML_8class_10.img (to indicate the prob. threshold).
     5. Select "Yes" for the Output Rule Images
     6. Name the rule images OLI_ITH_8class_rule.img.
     7. Select OK

4. **Display the classified image and visually evaluate the results.**
   a. Note that the colors match the colors chosen for the training data.
   b. What is your visual impression of the classification? Note in particular that the low-density residential areas are captured surprisingly. This was not an obvious outcome in the Red-IR scatterplot.
   c. In the Max Like image window, select Tools > 2-D Scatterplot, and select bands 4 and 5 from the OLI_Ithaca_Sep2013.img. This will allow you to use image dance to explore the classifications in the scatterplot by dragging the cursor in the Max Like image window. Consider other band combinations. (Can you find a band combination that helps to discriminate the low-density residential class from forest?)
   d. Examine the unclassified areas using image dance. In particular consider:
      1. Water
      2. The grass area around the airport
   e. Could you improve the classification by choosing additional training areas?
5. Create a confusion (contingency) Matrix
ENVI’s confusion matrix function allows comparison of two classified images (the classification and the “truth” image), or a classified image and ROIs representing ground truth observations.

If the ROI tool window has been closed, re-open it. Select **Tools > Region of Interest > ROI Tool**

- Delete the training ROIs from the ROI tool window. In the ROI tool window, highlight all of the ROIs beginning with "trn_" by clicking in the left column while holding down the CTRL button, then select **Delete ROI**. (This is not absolutely necessary, but will avoid unnecessary confusion.)

- Select **File > Restore ROIs**, and select **OLI_Ithaca_8class_test.roi**

- Select **Classification > Post Classification > Confusion Matrix > Using Ground Truth ROIs**. The Classification Input File Window appears.

- In the **Classification Input File Window** select the classified image **OLI_Ithaca_ML_8class_10.img**. Select OK. The Match Classes Parameters window appears.

- Match each of the test ROIs with the corresponding training training ROI and select **Add Combination** as shown at right. Continue until only the Unclassified category remains in the Classification image list.

- Select OK. The **Confusion Matrix Parameters** window appears. Select all outputs: Confusion Matrix in pixels and percent as well as the Accuracy Assessment Report.

- Select OK. The **Class Confusion Matrix** window appears. Expand the window to view as much of the table as possible. The display shows only 5 columns of data, so the 8 classes are split into groups.

The report shows the overall accuracy, kappa coefficient, confusion matrix, errors of commission (percentage of extra pixels in class), errors of omission (percentage of pixels left out of class), producer accuracy, and user accuracy for each class.

**Prod. Acc.**: probability that a pixel known to be in class is assigned to class X.

**User Acc.**: probability that a pixel assigned to class X actually belongs to class X.

**Confusion matrix**: output shows these accuracy assessments for each class.
Evaluate the Confusion Matrix

- How "good" is the classification according to the confusion matrix?
- Consider the User's and Producer's Accuracies. Is one significantly better than the other?
- Are there any obvious problems with the classification based on the confusion matrix?
- Compare the classified image to the original image:

  - How would you rate the classification based on a visual evaluation of the classification image?
    - How does your visual evaluation compare to the numerical evaluation?
    - Does the confusion matrix capture the uncertainties in the classification?
    - For instance, consider the water class. Is the classification really 100% accurate?
    - Are there water pixels that are not classified as water?
    - Are there pixels classified as water that should not have been?
    - Are there pixels that should have remained unclassified: e.g., cars in the parking lot, buildings, …

<table>
<thead>
<tr>
<th>Class</th>
<th>Commission (Percent)</th>
<th>Omission (Percent)</th>
<th>Commission (Pixels)</th>
<th>Omission (Pixels)</th>
</tr>
</thead>
<tbody>
<tr>
<td>trn_veg-dense</td>
<td>0</td>
<td>59.41</td>
<td>0/315</td>
<td>461/776</td>
</tr>
<tr>
<td>trn_veg-med</td>
<td>10.76</td>
<td>52.03</td>
<td>27/251</td>
<td>243/467</td>
</tr>
<tr>
<td>trn_forest</td>
<td>13.26</td>
<td>13.48</td>
<td>266/2006</td>
<td>271/2011</td>
</tr>
<tr>
<td>trn_soil [Ora]</td>
<td>86.21</td>
<td>93.19</td>
<td>225/261</td>
<td>493/529</td>
</tr>
<tr>
<td>trn_asph-conc</td>
<td>22.17</td>
<td>23.61</td>
<td>94/424</td>
<td>102/432</td>
</tr>
<tr>
<td>trn_water [Bl]</td>
<td>0</td>
<td>15.27</td>
<td>0/8940</td>
<td>1611/10551</td>
</tr>
<tr>
<td>trn_LDres [Ma]</td>
<td>7.02</td>
<td>28.91</td>
<td>85/1211</td>
<td>458/1584</td>
</tr>
<tr>
<td>trn_veg-emrg</td>
<td>41.91</td>
<td>58.19</td>
<td>197/470</td>
<td>380/653</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>trn_veg-dense</td>
<td>40.59</td>
<td>100</td>
<td>315/776</td>
<td>315/315</td>
</tr>
<tr>
<td>trn_veg-med</td>
<td>47.97</td>
<td>89.24</td>
<td>224/467</td>
<td>224/251</td>
</tr>
<tr>
<td>trn_forest</td>
<td>86.52</td>
<td>86.74</td>
<td>1740/2011</td>
<td>1740/2006</td>
</tr>
<tr>
<td>trn_soil [Ora]</td>
<td>6.81</td>
<td>13.79</td>
<td>36/529</td>
<td>36/261</td>
</tr>
<tr>
<td>trn_asph-conc</td>
<td>76.39</td>
<td>77.83</td>
<td>330/432</td>
<td>330/424</td>
</tr>
<tr>
<td>trn_water [Bl]</td>
<td>84.73</td>
<td>100</td>
<td>8940/10551</td>
<td>8940/8940</td>
</tr>
<tr>
<td>trn_LDres [Ma]</td>
<td>71.09</td>
<td>92.98</td>
<td>1126/1584</td>
<td>1126/1211</td>
</tr>
<tr>
<td>trn_veg-emrg</td>
<td>41.81</td>
<td>58.09</td>
<td>273/653</td>
<td>273/470</td>
</tr>
</tbody>
</table>
6. Use the Rule Images to adjust the classification.

View the Rule images

The rule images are gray-value images showing the discriminant function value for each pixel. The brightness of a pixel represents the probability that the pixel belongs to a particular class. There is one rule image for each class identified by an ROI. Regardless of the original classification results, one may redo the classification by adjusting the thresholds used for each rule image.

a. Select Classification > Post Classification > Rule Classifier

b. Select the rule images.

Note: the colors assigned to the rule images are ENVI’s default color pallet, not the colors used to define the training or test ROIs. You can reset the colors to match those in the ROIs by selecting Options > Edit Class colors/names. This window allows you to reset each class color individually.

c. Enter a 0.00 in the Set All Thresholds box and select Set All Thresholds. This sets the value for the discriminant function.

d. Select Quick Apply to display the resulting classified image. Since a limit has been placed on the discriminant functions, there are pixels which do not meet the classification criterion for any of the classes. These appear black in the classified image.

e. For a given class, display the histogram to get an idea of the overall distribution for the specific discriminant function. Note: the range of the distribution function is very large and most of what is of interest is in the higher values. Positive numbers (and small, negative numbers) represent a high probability of correct classification. As the values decrease and become more negative, the probability of correct classification decreases. Consider the distribution function for bare soil which ranges from -22800 to -35.13 (see figure below). In order to view the upper range of the scale, adjust the scale by selecting Edit > Plot Parameters and changing the lower limit of the x-axis. In the example, a value of -3-30000 makes the important details of the distribution visible.
f. Adjust the values of the thresholds for the classes as a group or individually. Use **Quick Apply** to see the effect of your choice on the classification. As an example, try the water class since that is easy to visualize. The goal would be to completely classify Cayuga lake (and any other lakes, rivers, etc.) without misclassifying land areas.

   i. Adjust the rule image to capture as much of the water as possible. Can that be done without misclassifying land features as water?

   ii. Locate the locus of water on the 2-D histogram. Can you define a locus that works better than can be done with the rule image?

h. Continue with the other categories, adjusting the bounds of the classification until you are "satisfied" with the result. An example of the final product appears below.

![Classification result](image_url)